Cargando

Ir a contenido

X

ENVIAR EMAIL - VISUAL BASIC





  AUTOR PREGUNTA

Publicado 29 octubre 2014 - 16:55
me han pedido incrustrar una imagen en un mensaje de email, el email llega exitosamente pero no reconoce la imagen estoy utilizando "Microsoft CDO for WINDOW 2000 Library" y agrego la etiqueta <img src ="xxxx.jpg"></img> pero no me reconoce
la imagen a continuacion mi codigo completo.
NOta. La imagen se encuentra en una carpeta llamada imagenes dentro de mi proyecto

Imports WebAnuncios.ServicioAnuncio
Public Class AdminLogueo2
Public Sub Envia_EmailRecuperacion(ByVal bean As EA_Usuario)
	 Dim oMsg As New CDO.Message
	 Dim iConfig As CDO.Configuration
	 Dim oFields As ADODB.Fields
	 iConfig = oMsg.Configuration
	 oFields = iConfig.Fields
	 Dim oField As ADODB.Field
	 Try
		 oField = oFields("http://schemas.microsoft.com/cdo/configuration/sendusing")
		 oField.Value = 2
		 oField = oFields("http://schemas.microsoft.com/cdo/configuration/smtpserver")
		 oField.Value = "miemail.empresa.com.pe"
		 oField = oFields("http://schemas.microsoft.com/cdo/configuration/smtpserverport")
		 oField.Value = 25
		 oField = oFields("http://schemas.microsoft.com/cdo/configuration/smtpusessl")
		 oField.Value = False
		 oField = oFields("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate")
		 oField.Value = 1
		 oField = oFields("http://schemas.microsoft.com/cdo/configuration/sendusername")
		 oField.Value = "servicioalcliente"
		 oField = oFields("http://schemas.microsoft.com/cdo/configuration/sendpassword")
		 oField.Value = "12345678"
		 oMsg.Configuration = iConfig
		 oMsg.Subject = "Recuperacion de Contraseña"
		 oMsg.From = "servicioalcliente@empresa.com.pe"
		 oMsg.To = bean.VchEmail.ToString()
		 oMsg.HTMLBody = "Hola " & bean.VchNombres & " " & bean.VchApellidos &
			 "<img src='"imagenes/imagen.jpg"'></img>"
		 oFields.Update()
		 oMsg.Send()
		 oMsg = Nothing
		 iConfig = Nothing
		 oFields = Nothing
		 oField = Nothing
	 Catch ex As Exception
		 MsgBox("Problemas con el servidor... Intente mas tarde")
		 Return
	 End Try
End Sub
End Class

Adjuntos:


  • ¿Tienes la misma pregunta? Yo también
  • Volver arriba


 

Publicado 29 octubre 2014 - 18:20
No soy experta en Visual Basic, sin embargo la lógica debe ser la misma, que debes agregar las cabeceras con el tipo de content-type para poder enviar HTML por correo, por eso no te reconoce el tag IMG, podría ser algo como esto:

oMsg.HTMLBody = "MIME-Version: 1.0' . "\r\n
Content-type: text/html; charset=iso-8859-1' . "\r\n"


Y luego agregas los demás valores que tienes en tu código original.


X