Cargando

Ir a contenido

X


Ver Más! Si eres de los que tiene o se va a comprar Huawei Mate 20, o Mate 20 Pro. Aquí tienes colección de tutoriales que se irán actualizando diariamente con todas las opciones que te ofrece este genial terminal móvil!


Problemas con enrutamiento con parametros (Laravel)



2 Respuestas de expertos

#1   lxevilx

  •   Reputación:11
  •   Respuestas:16

Publicado 18 marzo 2016 - 16:20

Buenas a todos una vez mas, estoy aqui con una nueva duda sobre las rutas (routes)

 

resulta que tengo el siguiente codigo

Por favor Identificate o Registrate para poder ver este contenido

es ahi donde mando el id del objeto que se obtendra su informacion.

 

todo marcha bien hasta ahi, cargan los datos y todo super pero al dirigirme a otra pagina por ejemplo almacenes que esta en un boton de la pagina esta me direcciona a:

 

Por favor Identificate o Registrate para poder ver este contenido

Obviamente no encuentra nada porque mi ruta es 

Por favor Identificate o Registrate para poder ver este contenido

es decir esta tendria q direccionarme a  

Por favor Identificate o Registrate para poder ver este contenido

Hay alguna forma de solucionar este problema, probe con borrar el where, pero me redirecciona a la misma pagina Rubro

Gracias de antemano por su colaboracion. 


  • ¿Tienes la misma pregunta? Yo también
  • Volver arriba

#2   Alfonso

  •   Reputación:54
  •   Respuestas:92
  •   Tutoriales:7

Publicado 18 marzo 2016 - 21:33

No lo veo mal así directamente. Te recomiendo que le eches un ojo a esta parte de documentación Laravel para el routing:

 

Por favor Identificate o Registrate para poder ver este contenido

 

si bajas abajo verás que está la opción que estás utilizando con redirections.

 

Ya nos cuentas como lo solucionaste o que fue.



#3   lxevilx

  •   Reputación:11
  •   Respuestas:16

Publicado 21 marzo 2016 - 15:23  AUTOR PREGUNTA

Gracias por tu respuesta, bueno ya lo solucione....!!!!

Solo era el error en los links, antes estaba asi:

Por favor Identificate o Registrate para poder ver este contenido

solo le añadi "../" y ahora se direcciona correctamente

Por favor Identificate o Registrate para poder ver este contenido




No esperes más y entra en Solvetic
Deja tus soluciones y aprovecha las ventajas de la cuenta de usuario ¡Únete!

x

¿Tienes otra pregunta? Aquí puedes encontrar más soluciones!

¿Sigues sin solución? Realiza tu pregunta gratis en Solvetic ¡Únete!