Cargando

Ir a contenido

X

Tengo un problema cuando importo desde una tabla de excel en phpmyadmin con extension .csv o .xlsx





#1   Fernan

Publicado 03 febrero 2014 - 21:03
Tengo un problema importo desde una tabla de excel en phpmyadmin con extension .csv o .xlsx y en ambas me sale el campo de fecha con numeros erroneos ejemplo importo 29/01/2014 y sale 41203. Como lo resuelvo?
  • ¿Tienes la misma pregunta? Yo también
  • Volver arriba


#2   Sergio Culoccioni

Publicado 04 febrero 2014 - 21:51
En este caso deberías utilizar una función para que excel formatee la el campo fecha a formato mysql, puedes utilizar la función.

=TEXTO(A1;"AAAA-MM-DD")

Esto genera un texto 2014-01-29 que se exportará exactamente igual al csv y mysql va a entender como una fecha solucionando asi el problema.