Cargando

Ir a contenido

X


Ver Más! Si te gusta crear vídeos con tus mejores fotos o montajes de vídeos en DVD o Blu-ray, Wondershare DVD Creator es tu programa. Haz clic en el enlace, conoce todo lo que ofrece y cómo usarlo.


Tengo un problema cuando importo desde una tabla de excel en phpmyadmin con extension .csv o .xlsx



1 Respuestas

#1   Fernan

  •   Reputación:14
  •   Respuestas:47
  •   Tutoriales:2

Publicado 03 febrero 2014 - 21:03

Tengo un problema importo desde una tabla de excel en phpmyadmin con extension .csv o .xlsx y en ambas me sale el campo de fecha con numeros erroneos ejemplo importo 29/01/2014 y sale 41203. Como lo resuelvo?
  • ¿Tienes la misma pregunta? Yo también
  • Volver arriba

#2   Sergio Culoccioni

  •   Reputación:265
  •   Respuestas:62
  •   Tutoriales:173
1 0 0

Publicado 04 febrero 2014 - 21:51

En este caso deberías utilizar una función para que excel formatee la el campo fecha a formato mysql, puedes utilizar la función.

=TEXTO(A1;"AAAA-MM-DD")

Esto genera un texto 2014-01-29 que se exportará exactamente igual al csv y mysql va a entender como una fecha solucionando asi el problema.



No esperes más y entra en Solvetic
Deja tus soluciones y aprovecha las ventajas de la cuenta de usuario ¡Únete!



x

¿Tienes otra pregunta? Aquí puedes encontrar más soluciones!

¿Sigues sin solución? Realiza tu pregunta gratis en Solvetic ¡Únete!