Cargando

Ir a contenido

X

Tengo un problema cuando importo desde una tabla de excel en phpmyadmin con extension .csv o .xlsx





 

Publicado 03 febrero 2014 - 21:03
[font=arial,helvetica,sans-serif][size=4]Tengo un problema [color=#1A1A1A]importo desde una tabla de excel en phpmyadmin con extension .csv o .xlsx y en ambas me sale el campo de fecha con numeros erroneos ejemplo importo 29/01/2014 y sale 41203[/color][/size]. Como lo resuelvo?[/font]
  • ¿Tienes la misma pregunta? Yo también
  • Volver arriba


 

Publicado 04 febrero 2014 - 21:51
[font=arial,helvetica,sans-serif][size=4][color=#1A1A1A]En este caso deberías utilizar una función para que excel formatee la el campo fecha a formato mysql, puedes utilizar la función.[/color]

[color=#1A1A1A]=TEXTO(A1;"AAAA-MM-DD")[/color]

[color=#1A1A1A]Esto genera[/color][color=#1A1A1A] un texto 2014-01-29 que se exportará exactamente igual al csv y mysql va a entender como una fecha solucionando asi el problema.[/color][/size][/font]