Cargando

Ir a contenido

X

 


Función coincidir: Comparar datos entre columnas en Excel 2016

Te explicamos las diferentes formas para comparar dos columnas si los datos coinciden o no en Excel.


Escrito por el abr 03 2017 13:26 excel



Al trabajar con múltiples datos en Excel 2016 muchas veces nos vemos en la necesidad de comparar múltiples columnas para verificar si las celdas coinciden o no en su información. Esto es bastante práctico cuando debemos hacer comparaciones de datos.

 

Gracias a las múltiples opciones incluidas en Excel 2016 tenemos a mano múltiples posibilidades para llevar a cabo esta tarea siempre con integridad y veracidad en la información manejada. A continuación vamos a analizar las diferentes funciones.

 

 


1. Comparar columnas celda por celda


La primera opción que analizaremos será e realizar la búsqueda celda por celda de una forma automática. Para ello tenemos los siguientes datos:

 

 

Para comprobar si coinciden o no los valores usaremos la siguiente formula:

=SI(A2=B2; "Coincide";"No coincide")
Con esta indicamos que si el dato de la celda A2 es igual al dato en la celda B2 se despliegue el mensaje “Coincide”, de lo contrario se desplegara el mensaje “No coincide”. Esta fórmula la ingresamos en la celda C2 y la arrastramos al final del rango para copiarla, el resultado obtenido será el siguiente:

 

 

Comparar-columnas-celda-por-celda-excel-2.png

 

Podemos ver de forma exacta las celdas que coinciden y las que no. Es posible que deseemos buscar los datos diferentes entre las celdas, con el método anterior hemos buscado los datos iguales. Para buscar datos que sean diferentes usaremos la siguiente fórmula:

=SI(A2<>B2; "Coincide";"No coincide")

Comparar-columnas-celda-por-celda-excel-3.png

 


2. Comparar columnas distinguiendo entre mayúsculas y minúsculas


Esta es otra de las opciones importantes que debemos tener presentes a la hora de comparar columnas en Excel 2016 ya que en muchas oportunidades los datos, aunque son iguales, pueden estar en minúscula o mayúscula. Si deseamos ver los datos iguales, tanto en contenido como en escritura, usaremos la siguiente formula:
=SI(IGUAL(A2;B2); "Coincide"; "Único")
De esta forma los datos que estén iguales, incluido minúscula y mayúscula, desplegaran el mensaje Coincide, de lo contrario veremos Único:

 

Comparar-columnas-distinguiendo-entre-mayusculas-y-minusculas-4.png

 


3. Comparar múltiples columnas cuyo contenido sea igual en todas las filas


Si contamos con múltiples filas tenemos la posibilidad de compararlas todas para verificar si el contenido de las mismas es idéntico. En este caso tenemos tres columnas y usaremos la función Si y la función Y para realizar esta tarea de la siguiente forma:
=SI(Y(A2=B2; A2=C2); "Coinciden"; "No coinciden")
Podremos ver el resultado que solo desplegara el mensaje coinciden en donde las tres celdas son idénticas:

 

Comparar-múltiples-columnas-cuyo-contenido-sea-igual-en-todas-las-filas-excel-5.png

 

En caso de contar con múltiples columnas podemos hacer uso de la siguiente formula:

=SI(CONTARSI($A2:$F2; $A2)=6; "Coinciden"; "No coinciden")
Donde el 6 indica la cantidad de columnas a analizar.

 


4. Encontrar coincidencias en dos celdas en la misma fila


Otra de las opciones disponibles es encontrar coincidencias en por lo menos dos celdas de una misma fila y no en todas las celdas. Si deseamos validar esto usaremos las funciones Si y O de la siguiente manera:
=SI(O(A2=B2; B2=C2; A2=C2); "Coinciden"; "NoCoinciden")
Al usar esta sintaxis veremos el siguiente resultado:

 

Encontrar-coincidencias-en-dos-celdas-en-la-misma-fila-6.png

 


5. Comparar valores de una columna en otra


Con esta opción podemos comprobar que un valor de columna A se encuentre en la columna B, para esto usaremos las funciones Si y CONTAR.SI de la siguiente forma:
=SI(CONTAR.SI($B:$B; A2)=0; "No aplica en B";  "Aplica ")
Con esto indicamos que si el dato de la celda A esta en la columna B se despliegue el mensaje Aplica, de lo contrario se desplegara el mensaje No aplica en B. Podremos ver el resultado de la siguiente forma:

 

Encontrar-coincidencias-en-dos-celdas-en-la-misma-fila-7.png

 


6. Comparar datos entre columnas en Excel 2016 y extraer datos específicos


Muchos datos pueden encontrase en columnas diferentes y es necesario obtener un dato especifico del alguno de ellos y todos sabemos que la función más práctica para esto es BUSCARV la cual de forma automática extrae el valor de la columna que indiquemos.

 

Pero podemos hacer uso de las funciones INDICE y COINCIDIR para obtener el mismo resultado.
En este caso tenemos datos diversos y deseamos conocer el precio del producto indicado en la celda D2 tomando como base los rangos B2:B11, usaremos la siguiente formula:

=INDICE($B$2:$B$11;COINCIDIR(D2;$A$2:$A$11;0))

Comparar-datos-entre-columnas-en-Excel-2016-y-extraer-datos-especificos-8.png

 

Podemos ver que los datos registrados que existen en el rango A2:A11 desplegaran el respectivo precio, mientras que los datos inexistentes despliegan el error #N/A.

 


7. Comparar columnas y resaltar las coincidencias


Esta opción es funcional cuando deseamos resaltar los valores que se encuentran en una columna mas no en la otra.
Para esto seleccionamos las celdas a resaltar y vamos a la opción Formato condicional ubicada en el grupo Estilos y en las opciones desplegadas elegimos Nueva regla

 

 

Allí seleccionaremos la opción Utilice una fórmula que determine las celdas para aplicar formato y en el campo Dar formato a los valores donde esta fórmula sea verdadera ingresamos lo siguiente:

=$B2=$A2

nueva-regla-excel-10.png

 

Pulsamos en Aceptar para ver los resultados:

 

comparar-columnas-excel-11.png

 


8. Comparar múltiples columnas y resaltar las diferencias


Esto lo podemos realizar gracias a una función especial incluida en Excel 2016. Para esto resaltamos las celdas a analizar, vamos a la ficha Inicio, grupo Modificar, pulsamos en Buscar y seleccionar y allí damos clic en la opción Ir a Especial:

 

 

Se desplegará el siguiente asistente donde activamos la casilla Diferencias entre filas:

 

diferencias-filas-excel-13.png

 

Pulsamos Aceptar y veremos las celdas con contenido diferente resaltadas.

 

comparar-columnas-excel-14.png

 

Usando alguno de los métodos descritos tenemos la posibilidad de comparar datos entre columnas de una forma funcional, segura y totalmente automática.

 



Tutoriales Relacionados



Sin comentarios, sé el primero!

No esperes más y entra en Solvetic
Deja tus comentarios y aprovecha las ventajas de la cuenta de usuario ¡Únete!
10
VOTA
5
100%
4
0%
3
0%
2
0%
1
0%

  Información

  •   Publicado abr 03 2017 13:26
  •   Actualizado abr 03 2017 13:37
  •   Visitas 111.1K
  •   Nivel
    Intermedio