Cargando

Ir a contenido

X

 


Cómo comparar datos y columnas Excel 2019

Tutorial con vídeo para saber cómo comparar datos y columnas en Excel 2019 de diferentes maneras.


Escrito por sep 24 2019 16:05 excel



Aunque el nombre Excel para muchos puede llegar a ser sinónimo de miedo y de complejidad, no lo es si tenemos los conocimientos adecuados. Sin embargo gracias a esta herramienta de hojas de cálculo, tenemos la posibilidad de realizar diferentes acciones de manera sencilla, gracias a la gran cantidad de fórmulas que podemos aplicar para gestionar datos.

 

Tutorial con videosolución para ordenar los datos alfabéticamente o de forma personalizada con filtros en Excel 2019.

 

Microsoft Excel es realmente una utilidad práctica para la gestión completa e integral de los datos a trabajar y una de las acciones que con mayor frecuencia ejecutamos en Excel 2019 es comparar datos de las celdas. Algo tan simple pero que puede sacar de muchos problemas ya que la comparación de datos es ideal para determinar la integridad de un dato en Excel.

 

Solvetic te explicará algunos métodos para comparar tanto datos como columnas en Excel 2019 y así administrar de una forma mucho más centralizada.

 

Tutorial para saber cómo crear y editar gráficos en Excel 2016 y Excel 2019 de diferentes formas.

 


1. Comparar columnas usando el método de celda por celda en Excel 2019

 

Paso 1

Como su nombre lo indica, este método se encarga de ejecutar la búsqueda a través de cada celda por celda en un proceso totalmente automático. En este caso disponemos de la siguiente información:

 

comparar-datos-y-columnas-Excel-2019-1.png

 

Allí vamos a añadir una nueva columna donde registraremos si los datos coinciden o no, en este caso será en la columna D y en la celda D2 ingresamos la siguiente fórmula:

=SI(B2=C2; "Coincide";"No coincide")
Paso 2

Con ella lo que realizamos es que se compara el valor de la celda B2 y si es igual que el valor de la celda B3 se lanzará el mensaje “Coincide”, en caso contrario veremos el mensaje “No coincide”:

 

 

comparar-datos-y-columnas-Excel-2019-2.png

 

Paso 3

Ahora, es posible buscar datos diferentes entre las celdas. Diferente a buscar los datos iguales, si deseamos buscar solo los datos diferentes vamos a usar la siguiente fórmula:
=SI(B2<>C2; "Coincide";"No coincide")

comparar-datos-y-columnas-Excel-2019-3.png

 


2. Cómo comparar columnas distinguiendo entre mayúsculas y minúsculas en Excel 2019


Muchas veces cuando gestionamos datos en Excel 2019, los datos de las columnas pueden estar ya sea en minúsculas o mayúsculas. Por ello, si deseamos visualizar los datos iguales, no importa si es en contenido o en escritura, vamos a usar la siguiente formula:
=SI(IGUAL(B2;C2); "Coincide"; "Es un valor único")

comparar-datos-y-columnas-Excel-2019-4.png

 

Allí podemos observar que, aunque algunos datos son lo mismo, su diferencia radica en las mayúsculas o minúsculas lo cual lo hace diferente.

 


3. Cómo comparar múltiples columnas en Excel 2019 donde su contenido sea igual en todas las filas


Otra de las opciones que nos ofrece Excel 2019 es la posibilidad de ver si los datos registrados en sus celdas son idénticos o no. Para esta tarea será necesario combinar las funciones Si y Y de forma simultánea, en este ejemplo ejecutaremos lo siguiente:
=SI(Y(B2=B3; B2=D2); "Coinciden"; "No coinciden")

comparar-datos-y-columnas-Excel-2019-5.png

 

Allí podemos observar que se lleva a cabo una comparación entre todas las columnas y solo el mensaje “Coinciden” se da donde todos los valores son idénticos.

 

Si disponemos de un gran número de columnas para analizar, podemos ejecutar lo siguiente:

=SI(CONTARSI($B2:$H2; $B2)=8; "Coinciden"; "No coinciden")
Allí el número 8 hace referencia a la cantidad de columnas a analizar.

 


4. Cómo encontrar coincidencias en dos celdas en la misma fila en Excel 2019


Excel 2019 nos da la oportunidad de encontrar coincidencias al menos en dos celdas de una misma fila mas no de forma general en todas las celdas del libro, para esto debemos combinar las funciones Si y O así:
=SI(O(B2=C2;CB2=D2; B2=D2); "Coinciden"; "No Coinciden")

comparar-datos-y-columnas-Excel-2019-6.png

 

Podemos ver que en donde esta dos veces el mismo término se desplegará el mensaje “Coinciden”, si no coincide en ninguna fila veremos “No Coinciden”.

 


5. Cómo comparar valores de una columna en otra en Excel 2019


Ahora, es posible que deseemos comparar si el valor de la columna A o B se encuentre en la columna B o C, en este caso debemos usar las funciones Si y CONTAR.SI de la siguiente forma:
=SI(CONTAR.SI($C:$C; B2)=0; "No aplica en C"; "Aplica ")
Al ejecutar esta fórmula, si el dato de la celda B está presente en la columna C veremos el mensaje “Aplica”, de lo contrario veremos el mensaje “No aplica en C”:

 

 

comparar-datos-y-columnas-Excel-2019-7.png

 


6. Cómo comparar datos entre columnas y extraer datos específicos Excel 2019


Algunos datos en Excel 2019 pueden estar distribuidos en columnas diferentes de modo que el uso de la función BUSCARV es ideal para acceder a dicho dato, pero en Excel 2019 podemos echar mano de las funciones INDICE y COINCIDIR para obtener dicha información de forma exacta.

 

En este ejemplo, deseamos obtener el crédito otorgado en base al nombre que ingresemos en la celda E4, y allí usaremos el rango de datos B2:B8 para la consulta, la fórmula a usar será la siguiente:

=INDICE($C$2:$C$8;COINCIDIR(E4;$B$2:$B$8;0))
Esta fórmula la registramos en la celda F4 y el nombre lo ingresamos en la celda E4 y allí obtendremos el resultado:

 

comparar-datos-y-columnas-Excel-2019-8.png

 


7. Cómo comparar las columnas y resaltar las coincidencias en Excel 2019


Este es un método mucho mas ideal para visualizar las coincidencias ya que será posible que las celdas donde se aplican los valores respectivos sean resaltados gracias al formato de celdas.

 

Paso 1

Si deseamos este método debemos seleccionar el rango de celdas a resaltar e ir a la opción “Formato condicional” ubicada en el grupo “Estilos” y en las opciones desplegadas elegimos “Nueva regla”:

 

 

Paso 2

En la ventana desplegada seleccionamos la línea “Utilice una fórmula que determine las celdas para aplicar formato” y en el campo “Dar formato a los valores donde esta fórmula sea verdadera” ingresamos la siguiente fórmula:
=$C2=$B2

comparar-datos-y-columnas-Excel-2019-10.png

 

Paso 3

Para establecer el resaltado, damos clic en Formato y luego elegimos el color deseado desde la pestaña “Relleno”:

 

 

Paso 4

Pulsamos en Aceptar para visualizar los resultados:

 

comparar-datos-y-columnas-Excel-2019-12.png

 


8. Cómo comparar múltiples columnas y resaltar las diferentes en Excel 2019


Esto será posible con una función especial de Excel 2019 asociada al pegado especial.

 

Paso 1

Para hacer uso de ella iremos al menú Inicio, grupo Edición, pulsamos en Buscar y seleccionar y allí daremos clic en la opción Ir a Especial pero antes seleccionamos las celdas a analizar:

 

 

Paso 2

En el asistente que se desplegará debemos activar la casilla “Diferencias entre filas”:

 

comparar-datos-y-columnas-Excel-2019-14.png

 

Paso 3

Al pulsar en Aceptar podremos visualizar los datos diferentes en el rango seleccionado:

 

comparar-datos-y-columnas-Excel-2019-15.png

 


9. Cómo comparar fechas en Excel 2019


Si eres usuario frecuente de Excel 2019 habrás notado que las fechas son uno de los datos mas usados en Excel y con el cual se pueden presentar mas errores por el formato del mismo, pero si deseas comparar fechas en Excel para determinar cual es mayor que otra, Solvetic te dará la respuesta de forma simple.

 

Paso 1

Para este ejemplo tenemos un rango de fechas en la columna C y tomaremos una fecha base (celda F3) con el fin de comparar que fechas son mayores a esta:

 

comparar-datos-y-columnas-Excel-2019-16.png

 

Con el fin de ejecutar la comparación ingresaremos la siguiente fórmula:

=SI(C2>$F$3; "Es mayor"; "No es mayor")
Paso 2

Allí, hemos establecido la celda base (F3) como un valor absoluto de modo que al comparar la columna C con dicha celda veremos que si la fecha es menor o igual será desplegado el mensaje “No es mayor” pero si la fecha es mayor veremos “Es mayor”:

 

 

comparar-datos-y-columnas-Excel-2019-17.png

 

Vemos como el manejo de Excel 2019, aunque parezca algo extremo, con Solvetic es algo simple y divertido con lo cual obtener la información necesaria no se convertirá en un calvario.

 

Tutorial sobre cómo borrar o eliminar datos de varias celdas seleccionadas en Excel 2019 paso a paso.



AYUDA A MEJORAR ESTE TUTORIAL!

¿Crees que puedes corregir o mejorar este tutorial? Puedes enviar tu Edición con los cambios que consideres útiles.

0 usuarios han editado este tutorial. ¡Edita y conviértete en un reconocido experto!


Tutoriales Relacionados



Sin comentarios, sé el primero!

No esperes más y entra en Solvetic
Deja tus comentarios y aprovecha las ventajas de la cuenta de usuario ¡Únete!
10
VOTA
5
100%
4
0%
3
0%
2
0%
1
0%

  Información

  •   Publicado sep 24 2019 16:05
  •   Visitas 1K
  •   Nivel
    Intermedio