Cargando

Ir a contenido

X

Magento filtros en reglas de precios no funciona





12 Respuestas de expertos

#1   Antonio C Montes

Publicado 28 abril 2015 - 11:24

Buenas a todos,

Hemos actualizado a la version 1.9.1 de Magento CE y al preparar una promoción con una regla de precios en el carrito, en la parte de "Acciones- Solo aplicar la regla a los articulos que cumplan las siguientes condiciones..." aunque lo configure como he hecho siempre, ahora no parece funcionar ... y la regla se aplica igual....

 

Le ha pasado esto ha alguien???

Esta claro que no es un problema de plantilla....

 


  • ¿Tienes la misma pregunta? Yo también
  • Volver arriba


#2   Juan Carlos

Publicado 28 abril 2015 - 11:49

Yo tuve un problema parecido cuando hice una actualización, pero en mi caso fue problema de plantilla, que no quedó replicada. ¿No puedes entrar en BBDD y ver si salta error con el filtro?



#3   Antonio C Montes

Publicado 28 abril 2015 - 11:51  AUTOR PREGUNTA

Yo tuve un problema parecido cuando hice una actualización, pero en mi caso fue problema de plantilla, que no quedó replicada. ¿No puedes entrar en BBDD y ver si salta error con el filtro?

Donde en la BBDD puedo ver eso???..... 



#4   Nestor1

Publicado 28 abril 2015 - 11:57

Donde en la BBDD puedo ver eso???..... 

 

Si es phpmyadmin es entrando en ella, seleccionar la BBDD y ver los Logs de errores, aplica el filtro, actualizas los logs y chequea que tipo de error sale, sino sale pues es que se aplica bien y será otro problema.

 

Para saber cual es el nombre de tu bbdd entra en el archivo:

 

/magento/app/etc/local.xml (Puede que lo tengas en otro directorio)

 

y ahí te viene el password y nombre de bbdd que estás utilizando.



#5   Antonio C Montes

Publicado 28 abril 2015 - 12:09  AUTOR PREGUNTA

Si es phpmyadmin es entrando en ella, seleccionar la BBDD y ver los Logs de errores, aplica el filtro, actualizas los logs y chequea que tipo de error sale, sino sale pues es que se aplica bien y será otro problema.

 

Para saber cual es el nombre de tu bbdd entra en el archivo:

 

/magento/app/etc/local.xml (Puede que lo tengas en otro directorio)

 

y ahí te viene el password y nombre de bbdd que estás utilizando.

No parece que haya ningún error relacionado.



#6   Fran Pazos

Publicado 28 abril 2015 - 12:24

No parece que haya ningún error relacionado.

 

No sé si será tu caso pero una vez los filtros no me iban por el valor de la categoría (donde creas filtro) 'Is anchor' ponlo en yes

 

Es dentro de

 

  1. Categorias
  2. Manage categories (Administrar Categorías) en configuraciones certifica que la opción "Is Anchor" está activada en yes y los filtros funcionarán.


#7   Antonio C Montes

Publicado 28 abril 2015 - 12:26  AUTOR PREGUNTA

No sé si será tu caso pero una vez los filtros no me iban por el valor de la categoría (donde creas filtro) 'Is anchor' ponlo en yes

El problema no es los filtros dentro de una categoria... sino el la regla de precios (cupones)



#8   Antonio C Montes

Publicado 28 abril 2015 - 12:27  AUTOR PREGUNTA

He encontrado de momento una solución "apaño"... 

Si en vez de aplicar filtros negativos por ej: Categorias-no es una de- etc.....

aplico Categorias- Es una de -.....

 

Funciona....



#9   Fran Pazos

Publicado 28 abril 2015 - 12:30

He encontrado de momento una solución "apaño"... 

Si en vez de aplicar filtros negativos por ej: Categorias-no es una de- etc.....

aplico Categorias- Es una de -.....

 

Funciona....

 

Ah! Pensaba que era sobre cats. El apaño que mencionas no lo había testeado. Me lo apunto (Guardado en favoritos jeje, seguro que más adelante me sirve)



#10   Nestor1

Publicado 28 abril 2015 - 12:46

He encontrado de momento una solución "apaño"... 

Si en vez de aplicar filtros negativos por ej: Categorias-no es una de- etc.....

aplico Categorias- Es una de -.....

 

Funciona....

 

Gracias por tu punto. Buen apaño has hecho. Hay veces que da este tipo de errores y en actualizaciones más.