Cargando

Ir a contenido

X


Ver Más! Unir varios PDF en uno en Windows 10 nunca fue tan fácil! Sigue los pasos con PDFelement y estará listo en un abrir y cerrar de ojos.


 


Cómo contar caracteres en Excel 2016

Te damos las fórmulas para contar caracteres en Excel 2016 de una celda, columna, rango, etc.


Escrito por el abr 19 2017 16:32 excel



Excel es sin duda una de las aplicaciones que más utilidad tiene pero que más desconocidas son sus diferentes funciones. Sin duda es una gran herramienta para la gestión y orden de datos.

 

Una de las tareas poco frecuentes que realizamos en Excel 2016 es saber con certeza cuantos caracteres tiene una celda o un rango determinado y es que, a diferencia de Word 2016, Excel no ofrece el conteo automático de caracteres.

 

Solvetic hoy analizará algunas formas para conocer exactamente cuántos caracteres tenemos dentro de una celda especifica o dentro de un determinado rango. De este modo vamos a poder llevar la cuenta sobre aquello que necesitemos sin tener que andar contando de manera manual. A continuación se muestran las diferentes opciones a la hora de contar caracteres en Excel.

 

 


1. Cómo contar los caracteres totales de una celda


Para contar caracteres en Excel podemos utilizar la función LARGO. En este ejemplo vamos a contar el número de caracteres de la cadena de texto de la celda A1. Para ello utilizamos la fórmula siguiente.

 

Nota
Recuerda que en función de la version que tengas de Excel (Español o Inglés) la fórmula que debes utilizar es diferente.

 

Español
=LARGO(A1)

 

Ingles
=LEN(A1)

 

Cómo vemos en la imagen en la celda B1 aparecerá el número de caracteres que contiene la celda A1

 

contar-caracteres-excel-0.jpg

 


2. Cómo contar caracteres en un rango


Esta es quizás una de las opciones más usadas cuando se trata de contar los caracteres ingresados en Excel 2016.
Para esto podemos usar algunas fórmulas como:
=LARGO(A1)+ LARGO (A2)+ LARGO (A3)…
 =SUMA(LARGO(A1);LARGO(A2)…
Estas fórmulas nos permiten sumar pequeños rangos dentro de Excel 2016 y podemos usar distintas celdas para su resultado:

 

 

 

Pero si tenemos un rango mucho más amplio, en el cual hacerlo de forma manual resulta una tarea complicada, debemos usar la función SUMAPRODUCTO, y la sintaxis será la siguiente:

=SUMAPRODUCTO(LARGO(rango))

 

Con esta opción la función LARGO calcula la longitud de los caracteres seleccionados y la función SUMA o SUMAPRODUCTO se encargan de la suma de estos caracteres.

 


3. Cómo contar caracteres específicos en una celda en Excel 2016


Esta opción aplica cuando debemos contar un numero definido de caracteres dentro de unan celda, ya sean letras, números o caracteres especiales.

 

En este caso será necesario usar las funciones LARGO y SUSTITUIR. La sintaxis a usar será la siguiente:

=LARGO(celda)-LARGO(SUSTITUIR(celda; caracter,""))
En este ejemplo contaremos cuantas veces esta la letra “e” en la celda C2:
=LARGO(C2)-LARGO(SUSTITUIR(C2; "e";""))

 

Podemos ver que efectivamente la letra “e” esta 2 veces en dicha celda,

 

Con esta fórmula se cumplen las siguientes condiciones:
  • En primer lugar se cuenta el total de la celda seleccionada (C2)
  • En segundo lugar usamos la función SUSTITUIR para quitar todas las veces que aparece el caracter seleccionado, en este caso “e” y se reemplazan por celdas vacías ""
  • Finalmente se cuenta la longitud de esta cadena sin el caracter indicado

 


4. Contar apariciones de una cadena especifica de texto en Excel 2016


Otra de las opciones que nos ofrece Excel 2016 es contar cuantas veces aparece una cadena especifica de caracteres en una celda definida.

 

Para esto usaremos la siguiente sintaxis aplicada a la celda A14. Podemos ver que la secuencia “en” figura dos veces en dicha celda.

=(LARGO(A14)-LARGO(SUSTITUIR(A14; "en";"")))/LARGO("en")

 


5. Contar caracteres de una celda


Esta es la función básica de contar cuantos caracteres existen en una celda ya que solo basta usar la siguiente sintaxis:
=LARGO(Celda)

 

Así sabremos con certeza cuantos caracteres tiene una celda en Excel 2016. Hemos comprendido como Excel 2016 se constituye en una poderosa herramienta con grandes y variadas funcionalidades para la tarea diaria de gestión de datos los cuales pueden ser en algún momento bastantes.

 


Tutoriales Relacionados


Sin comentarios, sé el primero!

No esperes más y entra en Solvetic
Deja tus comentarios y aprovecha las ventajas de la cuenta de usuario ¡Únete!
10
VOTA
5
100%
4
0%
3
0%
2
0%
1
0%

  Información

  •   Publicado abr 19 2017 16:32
  •   Actualizado abr 19 2017 16:43
  •   Visitas 6.2K
  •   Nivel
    Intermedio