Cargando

Ir a contenido


 


Función COUNTIF: Cómo contar tipos de celdas Excel 2016

Te explicamos cómo utilizar las diferentes opciones de la función COUNTIF o CONTAR.SI, para contar celdas que cumplen con un criterio en Excel.


Escrito por el mar 31 2017 11:56 excel office



Excel 2016 es una herramienta de hojas de cálculo desarrollada por Microsoft con el fin de permitirnos llevar un control y gestión de los datos de una forma dinámica, pero a la vez ordenada y acorde al tipo de datos registrados. Existen numerosas opciones y tareas que podemos llevar a cabo en Excel 2016 y a continuación nos centraremos en una en particular llamada CONTAR.SI o COUNTIF (Si Excel 2016 está en inglés).

 

Qué es CONTAR.SI / COUNTIF en Excel 2016
Básicamente la función CONTAR.SI o COUNTIF nos permite contar las celdas que cumplen con un criterio definido, de este modo solo cuando el valor que hemos indicado está dentro del rango seleccionado se aplicara la función.

 

Gracias a esta función podemos especificar múltiples valores de búsqueda tal como números, texto, etc, permitiéndonos saber con certeza cuántos de estos datos están registrados en el rango definido.

 

Sintaxis de la función CONTAR.SI / COUNTIF

La sintaxis que debemos tener en cuenta para el uso de esta función es la siguiente:
=CONTAR.SI(rango; condición)
Donde:
  • Rango (uso obligatorio): Hace referencia al rango de celdas sobre el cual será aplicada la condición para considerar su cuenta.
  • Condición (uso obligatorio): Indica la condición o parámetro que se debe cumplir una celda para ser incluido en la cuenta a desplegar.

 

A continuación veremos algunos ejemplos de cómo usar la función CONTAR.SI o COUNTIF en Excel 2016.

 


1. Fórmula para textos o números que coinciden con el parámetro


Es el uso básico que le damos a esta función y consiste en seleccionar un determinado rango e indicar el parámetro a buscar en este. Por ejemplo usaremos la siguiente línea para contar las celdas que contienen la palabra Windows 10. Podemos ver que tres (3) celdas cumplen con la condición indicada.
=CONTAR.SI(B2:B11; "Windows 10")

 

Nota:
Cuando la búsqueda implica texto, este debe ir entre comillas para que la búsqueda sea correcta.

 

Si deseamos realizar este mismo proceso con un valor numérico este no debe ir entre comillas, simplemente ingresar el numero deseados, por ejemplo, validaremos cuantas veces se repite el número ocho (8):

=CONTAR.SI(B2:B11; 8)

 


2. Fórmula para contar números mayores o menores que un valor definido


Con la formula CONTAR.SI tenemos la posibilidad de contar las celdas que incluyen datos numéricos cuyo valor sea mayor o menor que el criterio indicado. En este caso queremos conocer cuantas celdas incluyen números mayores que seis (6), para esto ingresamos la siguiente sintaxis:
=CONTAR.SI(B2:B11; ">6")
Nota:

En este caso el parámetro debe ir entre comillas ya que incluye un signo matemático.

 

El resultado será el siguiente:

 

 


3. Fórmula con comodines


Los comodines (*) nos permiten realizar una búsqueda especifica o parcial de determinado contenido en las celdas seleccionadas. Podemos usar las siguientes opciones:

 

Búsqueda de una palabra completa:

Esto es útil cuando tenemos una serie de datos y deseamos conocer exactamente cuántas celdas contiene una palabra especial, por ejemplo, tenemos una serie de nombres y apellidos y deseamos saber cuántos usuarios tienen el apellido Reyes. Para esto ejecutamos la siguiente sintaxis:
=CONTAR.SI(B2:B11; "*Reyes*")
El resultado obtenido será el siguiente:

 

 

El asterisco o comodín permite encontrar todas las celdas con la secuencia de caracteres indicados.

 

Búsqueda de caracteres específicos

Es posible que en determinados momentos deseemos contar las celdas que inicien o terminen en caracteres específicos, para ello podemos usar el símbolo* o el símbolo ?. En este ejemplo contaremos las celdas que terminan en nte.
  • Si deseamos conocer las celdas que inician con nte usaremos la sintaxis nte*
  • Si deseamos conocer las celdas que terminan con nte usaremos la sintaxis *nte
=CONTAR.SI(A2:A11; "*nte")
Vemos el resultado de las celdas que terminan en nte dentro del rango seleccionado:

 

 

 


4. Fórmula para contar celdas vacías y con datos


En muchas ocasiones los rangos seleccionados cuentan con celdas vacías no detectables y deseamos conocer la cantidad total para llevar un mejor control sobre la tarea realizada.
Para encontrar la cantidad de celdas vacías y con datos en un rango usaremos las siguientes sintaxis:
  • Celdas con datos:
=CONTAR.SI(B2:B15; "*")
  • Celdas vacías:
=CONTAR.SI(B2:B15; "<>"&"*")
Podemos ver el respectivo resultado:

 


 


5. Fórmula para hallar valores menores, mayores o igual al parámetro indicado


Es sencillo hallar este tipo de valores en Excel 2016 con la formula CONTAR.SI o COUNTIF, basta agregar el respectivo operador de la siguiente forma:

 

Mayor que
Cuenta los números mayores a 3
=CONTAR.SI(B2:B11; ">3")

Menor que
Cuenta los números menores a 3
=CONTAR.SI(B2:B11; "<3")

Igual a
Cuenta los números iguales a 3
=CONTAR.SI(B2:B11; "=3")

No es igual a
Cuenta los números diferentes a 3
=CONTAR.SI(B2:B11; "<>3")

 

Mayor o igual que
Cuenta los números mayores o iguales a 3
=CONTAR.SI(B2:B11; ">=3")

Menor o igual que
=CONTAR.SI(B2:B11; "<=3")
cuenta los números menores o iguales a 3.

 

 


6. Fórmula para contar fechas en Excel 2016 con CONTAR.SI


Otro tipo de dato muy frecuente en Excel 2016 son las fechas y gracias a esta función tenemos la posibilidad de contar fechas tomando diversos criterios como lo explicamos a continuación:

 

Contar fechas iguales a la fecha actual
=CONTAR.SI(B2:B11; HOY())

Contar fechas anteriores a la fecha actual
=CONTAR.SI(B2:B11;"<"&HOY())

Contar fechas posteriores a la fecha actual
=CONTAR.SI(B2:B11;">"&HOY())

Contar fechas en una semana específica
=CONTAR.SI(B2:B11; "="&HOY()+7)

Contar fechas en un rango específico
=CONTAR.SI(B2:B11, ">=20/8/2015")-CONTAR.SI(B2:B11, ">15/9/2016")

 

 

 


7. Fórmula para contar datos con múltiples criterios


Con la función CONTAR.SI tenemos la oportunidad de aplicar diversos criterios de búsqueda con el fin de obtener mejores resultados en base a las necesidades que tengamos. Por ejemplo, contaremos las celdas cuyos datos sean mayores o iguales que dos y mayores o iguales 7 ingresamos lo siguiente:
=CONTAR.SI(B2:B11; ">=2")-CONTAR.SI(B2:B11; "<=7")

 

Otra de las formas posibles es combinar valores de texto y numéricos, por ejemplo, contaremos las celdas que sean mayores o iguales a 6 en un rango y que contengan la palabra Windows en otro rango, usaremos la siguiente sintaxis:

=CONTAR.SI(B2:B11; ">=6")+CONTAR.SI(A2:A11; "*Windows")

 

 


8. Encontrar duplicados en CONTAR.SI


Gracias a esta función tendremos la posibilidad de ubicar de manera sencilla la cantidad de datos duplicados en un rango.
Por ejemplo, para saber cuántas celdas tiene el valor FALSO usaremos la siguiente sintaxis:
=CONTAR.SI(B2:B11;  FALSO)

 

Como comprobamos gracias a la función CONTAR.SI o COUNTIF podremos realizar tareas para conocer de forma exacta cuantos datos tenemos en base a los criterios que establezcamos y de esta manera llevar un mejor control sobre toda la información.

 

¿Te ha gustado y ayudado este Tutorial?
Puedes premiar al autor pulsando este botón para darle un punto positivo
  • -
  • 0
10
VOTA
5
100%
4
0%
3
0%
2
0%
1
0%

  Información

  •   Publicado mar 31 2017 11:56
  •   Visitas 6.1K
  •   Nivel
    Avanzado



Tutoriales Relacionados


Sin comentarios, sé el primero!

No esperes más y entra en Solvetic
Deja tus comentarios y aprovecha las ventajas de la cuenta de usuario ¡Únete!
Demuestra que eres experto!
  ESCRIBIR TUTORIAL
Suscribirse