Cargando

Ir a contenido


Transferencia archivos de Ubuntu muy lenta, a hd externo formato NTFS



SOLUCIÓN ELEGIDA POR EL AUTOR

Iniciado por Marcos Riera , 25 junio 2017 - 18:55

Hola atari_civ, al copiar archivos grandes o gran cantidad no eres el primero que puede notar que la velocidad de escritura es baja. En NTFS sobre los 15MB/seg, o sea muy lento.

 

Deberías irte a 80-100 MB/seg cuando se formatea con ext4, por lo que no es un problema de hardware o la unidad externa en tu caso.

 

Mi recomendación también es que te pases a ext4 o exFAT es la mejor opción sin duda. Para mejorar velocidad sin formatear la unidad... Yo encontré formas de intentar mejorar la velocidad. Comprueba si tienes cpuspeed activo. Porque puede que Ntfs-3g necesita CPU y cpuspeed lo limite erróneamente porque le baje al notar I/O de proceso en carga no tire tanto de CPU en su tarea. O sea, que deberías intentar desactivar el servicio cpuspeed (en caso de que lo tengas habilitado). Luego intenta copiar y mira si te acelera el tema algo.

Ir a la solución

9 Respuestas de expertos

#1   atari_civ

  •   Reputación:0
  •   Respuestas:5

Publicado 23 junio 2017 - 11:38

Me he topado con un problema tras instalar Ubuntu en mi equipo de sobremesa, antes tenía Windows. En un principio pensaba que mi disco duro interno estaba dañado (aparentemente tenía un sector dañado) pero tras cambiarlo por otro similar, sigo sufriendo el mismo problema (afortunadamente no gaste un euro, si tiempo).

El problema consiste en que al transferir archivos de mi disco interno a otro externo, cuesta entre 1 y 2 horas en función del tamaño (entre 2 y 5Gb) y creo que la causa es que el externo está en NTFS.

 

He leído que quizás haya que instalar algún driver para solucionarlo ¿podéis ayudarme?

 

Gracias

 

Actualmente tengo instalado Ubuntu 14.0.5 LTS (es un ordenador viejo)

 


  • 6 personas más tuvieron esta duda Yo también
  • Volver arriba

#2   John Duque

  •   Reputación:92
  •   Respuestas:59
  •   Tutoriales:2
4 0 0

Publicado 23 junio 2017 - 12:04

Hola buenos días un abrazo.

 

Intenta formatear el disco con exFAT ya que es un sistema de archivos mucho mas eficiente y con mejores factores de compatibilidad para Linux e intenta de nuevo hacer la transferencia.

 

Quedamos atentos a cualquier noticia :)

 

Abrazos



#3   atari_civ

  •   Reputación:0
  •   Respuestas:5

Publicado 23 junio 2017 - 13:30  AUTOR PREGUNTA

Hola,

 

Quería evitar formatear el disco externo, no tengo otro donde respaldar. Y el disco interno es de mucho menor tamaño.

 

Gracias John Duque



#4   Francesc

  •   Reputación:30
  •   Respuestas:58
  •   Tutoriales:1

Publicado 24 junio 2017 - 18:42

Mi opinión y sugerencia..

  • Si puedes, compra un disco SSD, lo vas a notar mucho.
  • Punto dos, si puede ser USB 3.0 y tienes conexión 3.0 en tu equipo entonces vuelas copiando.
  • Transforma a formato exFAT a lo que dice John es otra buena opción para probar que tal la copia y su velocidad, algo mejorará.

 

Analiza el disco para ver si tiene errores y se queda pillado a veces en velocidad por eso, porque como dices que puede tener sectores mal, la cosa cambia.



#5   Marcos Riera

  •   Reputación:152
  •   Respuestas:200
  •   Tutoriales:54
2 1 0

Publicado 25 junio 2017 - 18:55

Hola atari_civ, al copiar archivos grandes o gran cantidad no eres el primero que puede notar que la velocidad de escritura es baja. En NTFS sobre los 15MB/seg, o sea muy lento.

 

Deberías irte a 80-100 MB/seg cuando se formatea con ext4, por lo que no es un problema de hardware o la unidad externa en tu caso.

 

Mi recomendación también es que te pases a ext4 o exFAT es la mejor opción sin duda. Para mejorar velocidad sin formatear la unidad... Yo encontré formas de intentar mejorar la velocidad. Comprueba si tienes cpuspeed activo. Porque puede que Ntfs-3g necesita CPU y cpuspeed lo limite erróneamente porque le baje al notar I/O de proceso en carga no tire tanto de CPU en su tarea. O sea, que deberías intentar desactivar el servicio cpuspeed (en caso de que lo tengas habilitado). Luego intenta copiar y mira si te acelera el tema algo.



#6   Nestor1

  •   Reputación:201
  •   Respuestas:321
  •   Tutoriales:37

Publicado 25 junio 2017 - 19:04

Aquí tienes explicación de ello.. lo mejor cambiar de NTFS al formato exFAT y te quitas de lios. Pero si quieres mejorar velocidad de NTFS lee esto:

 

 

¿Por qué el controlador es lento?
 
Normalmente, el rendimiento de E / S de NTFS-3G y los otros sistemas de archivos son muy comparables. Sin embargo, puede haber varias razones para el rendimiento real inadecuado en ciertos escenarios. Todos los componentes de software y hardware deben funcionar perfectamente juntos para obtener el mejor rendimiento posible y si sólo uno de ellos falla de alguna manera, el rendimiento general del sistema puede sufrir notablemente. Si el controlador NTFS-3G utiliza cerca de 100% de tiempo de CPU, normalmente es un problema de controlador, aunque no siempre. Por favor, vea los detalles y la explicación aquí.
 
Si el controlador NTFS-3G no utiliza cerca del 100% de tiempo de CPU, entonces el problema normalmente no está directamente relacionado con el controlador NTFS-3G ni causado por éste. Las explicaciones más
 
USB está funcionando en modo de baja velocidad (0,1875 MB / seg) o velocidad máxima (máximo 1,5 MB / seg) en lugar del modo de alta velocidad (máximo 60 MB / seg). El rendimiento del USB es excepcionalmente malo en Mac OS X. Muchos usuarios dijeron que Firewire es mucho más rápido. Tenga en cuenta que NTFS-3G es independiente del tipo de bus (USB, Firewire, SATA, PATA, etc), y el rendimiento general puede depender del tipo de bus y su calidad de controlador significativamente.
 
  • Hay un dispositivo USB lento conectado a uno de los puertos del concentrador USB al que está conectado el disco.
  • Uso de la opción de montaje de sincronización que obliga a escribir más en el dispositivo (no utilice la sincronización a menos que tenga una buena razón).
  • Discos de estado sólido (SSD), USB y otras unidades flash pueden tener muchas razones para el bajo rendimiento:
    • El rendimiento de escritura de algunos Intel y otros SSD puede caer drásticamente con el uso. El formateo de bajo nivel puede ayudar temporalmente.
    • El rendimiento de escritura de algunos Intel y otros SSD puede disminuir significativamente cuando se activa la característica de administración de resistencia de disco para permitir que el dispositivo tenga, como mínimo, cinco años de vida útil. El límite típico es de 20 GB escritos por día.
    • La escritura al azar y el funcionamiento paralelo de muchos flash, USB y hardware SSD puede ser tan bajo como 0,02 MB / s.
    • La desfragmentación provoca un rendimiento aún peor y acorta la vida útil de estas unidades.
    • Las particiones no están alineadas con los límites del bloque de flash.
    • Archivo pesado de archivos temporales y de archivos pequeños.
    • Actividad pesada del archivo de la página (intercambio).
  • DMA está desactivado. Compruebe el BIOS y utilice hdpram, sdparm, blktool en Linux.
  • Uso de un dispositivo integrado o un subsistema de E / S muy rápido (100+ MB / s, RAID).
  • Errores de hardware o de sector defectuoso. Compruebe los archivos de registro en / var / log.
  • Es posible que algunos controladores USB externos se apaguen durante la actividad de escritura, lo que puede provocar grandes retrasos en las operaciones de E / S.
  • No utilizar el controlador de rendimiento mejorado en Mac OS X.
  • Un software ignora errores o no tiene un manejo correcto de errores. En tales casos el problema a menudo se hace visible en NTFS-3G, no en el software defectuoso.
  • Algunas versiones de Nautilus tienen un error de rendimiento con archivos de más de 20 MB. El problema desaparece si se utilizan herramientas de línea de comandos o gestores de archivos alternativos, como Thunar o Konqueror.
  • No utilizar al menos NTFS-3G Versión 2009.3.8.
  • Estado: Una versión optimizada de alto rendimiento, principalmente para dispositivos electrónicos de consumo, está disponible comercialmente.
 
 
¿Por qué el controlador tiene una alta utilización de la CPU?
 
Las explicaciones más comunes son:
 
  • No utilizar al menos NTFS-3G Versión 2009.3.8.
  • Escribir archivos de varios GB en un volumen altamente fragmentado internamente.
  • Algunos programas utilizan los tamaños de bloques más ineficientes por defecto.
  • Un archivo muy escaso es regularmente escrito o actualizado.
  • Está utilizando compresión transparente (puede desactivar la compresión en conjunto usando la opción nocompression o deshabilitar la compresión por directorio).
  • Algunos programas de software hacen operaciones intensivas de archivos a veces (Beagle, Amarok collectionscanner, updatedb, Spotlight, etc).
  • El uso de la CPU no es visible directamente en el caso de los controladores del sistema de archivos del kernel, pero esto no es cierto para los controladores de espacio del usuario. Es decir, están en la lista de procesos a diferencia de los controladores del kernel. Un uso más alto de la CPU es normal y se espera en algunos escenarios. Esto es cierto para la mayoría de los sistemas de archivos, no sólo NTFS-3G.
  • El tamaño de bloque NTFS (tamaño de clúster) es menor que 4096 bytes. Esto sucede a menudo, por ejemplo, si FAT32 se convirtió a NTFS. El controlador siempre registra esta información para los dispositivos de bloque. Puede buscar el valor de 'blksize' en los archivos de registro del sistema en el directorio / var / logs. Normalmente esta información se puede encontrar en el archivo de registro 'messages' o 'daemon.log', dependiendo de su sistema operativo.
  • Uso de un dispositivo integrado o un subsistema de E / S muy rápido (100+ MB / s, RAID).
  • VMware no está utilizando "mainMem.useNamedFile = FALSE" en el archivo .vmx.
  • Solución: el uso de la opción de montaje "big_writes" generalmente reduce el uso de la CPU, siempre que el software que solicite las escrituras admita bloques grandes.

 

Estado: Una versión optimizada de alto rendimiento, principalmente para dispositivos electrónicos de consumo, está disponible comercialmente.
 
¿Por qué está escribiendo archivos enormes ralentizando?
O usted no utiliza por lo menos NTFS-3G versión 2009.3.8 o su espacio de disco.
 
Más info aquí:
 

Por favor Identificate o Registrate para poder ver este contenido


 

Como ves hay muchos factores que pueden estar dando ese problema con NTFS (Descartando que sea por fallo de hardware del disco)



#7   Pablo Meria

  •   Reputación:112
  •   Respuestas:148
  •   Tutoriales:18
0 1 1

Publicado 25 junio 2017 - 19:16

Como detalle de este debate os digo que en la página de manual NTFS-3G se puede leer esto:
 
big_writes

This option prevents fuse from splitting write buffers into 4K
chunks, enabling big write buffers to be transferred from the
application in a single step (up to some system limit, generally
128K bytes).
 
 
  1. La opción big_writes probablemente no ayudará mucho en la velocidad de escritura de datos 4K.
  2. Existen drivers como comentas, que son especialidad, yo había oido de Paragon es libre para uso personal el driverNTFS que se llama NTFS & HFS para Linux 9.4 Express y una versión profesional.

Es otra opción... pruebalo y ya nos dirás si conseguiste que cogiera velocidad más rápida para NTFS en Linux (Ubuntu).

 

Por favor Identificate o Registrate para poder ver este contenido



#8   atari_civ

  •   Reputación:0
  •   Respuestas:5

Publicado 14 julio 2017 - 08:41  AUTOR PREGUNTA

Hola buenos días un abrazo.

 

Intenta formatear el disco con exFAT ya que es un sistema de archivos mucho mas eficiente y con mejores factores de compatibilidad para Linux e intenta de nuevo hacer la transferencia.

 

Quedamos atentos a cualquier noticia :)

 

Abrazos

 

Hola,

 

Formateé el disco externo con exFAT y funcionó, es decir, la velocidad de transferencia mejoró. Pero luego me topé con el inconveniente que al conectarlo a un reproductor, no reconcocía el disco.

Así que al final opté por formatear a ext4, y perfecto. El reproductor lo reconocío sin ningún problema. Dejé por si acaso una partición a NTFS en el mismo disco, por si la necesitaba, y listo.

 

Gracias por la ayuda



#9   atari_civ

  •   Reputación:0
  •   Respuestas:5

Publicado 14 julio 2017 - 08:50  AUTOR PREGUNTA

Hola atari_civ, al copiar archivos grandes o gran cantidad no eres el primero que puede notar que la velocidad de escritura es baja. En NTFS sobre los 15MB/seg, o sea muy lento.

 

Deberías irte a 80-100 MB/seg cuando se formatea con ext4, por lo que no es un problema de hardware o la unidad externa en tu caso.

 

Mi recomendación también es que te pases a ext4 o exFAT es la mejor opción sin duda. Para mejorar velocidad sin formatear la unidad... Yo encontré formas de intentar mejorar la velocidad. Comprueba si tienes cpuspeed activo. Porque puede que Ntfs-3g necesita CPU y cpuspeed lo limite erróneamente porque le baje al notar I/O de proceso en carga no tire tanto de CPU en su tarea. O sea, que deberías intentar desactivar el servicio cpuspeed (en caso de que lo tengas habilitado). Luego intenta copiar y mira si te acelera el tema algo.

 

Hola Marcos,

 

Me hice con otro disco duro externo y probé a formatear con ext4, la velocidad mejoró considerablemente. Luego, por si acaso, dejé una partición a NTFS y listo. Antes probé a formatear a exFAT, pero me topé con inconvenientes al conectarlo a un reproductor. No me lo reconocía.

 

Gracias por la ayuda.



#10   Luis Miranda

  •   Reputación:36
  •   Respuestas:60
  •   Tutoriales:1
2 0 1

Publicado 14 julio 2017 - 11:29

Hola Marcos,

 

Me hice con otro disco duro externo y probé a formatear con ext4, la velocidad mejoró considerablemente. Luego, por si acaso, dejé una partición a NTFS y listo. Antes probé a formatear a exFAT, pero me topé con inconvenientes al conectarlo a un reproductor. No me lo reconocía.

 

Gracias por la ayuda.

 

Me alegro que lo tengas ya mejor. Es mucho mejor para esos casos exFAT te quita de lios de drivers concretos porque aún así no llega bien.




No esperes más y entra en Solvetic
Deja tus soluciones y aprovecha las ventajas de la cuenta de usuario ¡Únete!

Preguntas Similares

  Preguntas Iniciado Por Estadísticas Último Mensaje

x

¿Tienes otra pregunta? Aquí puedes encontrar más soluciones!

No esperes más y entra en Solvetic! Solo te esperan ventajas ¡Únete!

Suscribirse