Cargando

Ir a contenido


 


Cómo copiar datos ignorando celdas vacías Excel 2016

Conoce todos los pasos necesarios para copiar datos ignorando celdas vacías en Excel 2016 dentro de este tutorial.


Escrito por el dic 22 2016 14:33 excel office



Excel 2016 es una herramienta vital cuando debemos gestionar grandes cantidades de datos de una manera sencilla pero con todo el potencial y veracidad que los mismos requieren. La cantidad de posibilidades que nos ofrece esta herramienta es inmensa, pudiendo crear algo tan útil como un checklist o la posibilidad de realizar diferentes gráficos.

 

Una de las tareas más comunes que realizamos en Excel 2016 es la copia de datos para pegar en otra hoja o libro de trabajo y aunque es una tarea sencilla puede causarnos problemas si dentro del rango de celdas que estamos copiando existen celdas vacías. A continuación vamos a ver cómo ignorar este tipo de celdas al momento de copiarlas a otra ubicación.

 


1. Cómo excluir celdas vacías al copiarlas

 

Paso 1

Este primer método consiste en definir los parámetros antes de copiar los datos y la función Ir a Especial será muy útil en este caso. Para ello seleccionamos la columna donde tenemos los datos a copiar:

 

 

Paso 2

A continuación vamos a la pestaña Inicio, grupo Modificar y allí seleccionamos la opción Buscar y seleccionar y de las opciones desplegadas elegimos la opción Ir a Especial

 

 

Paso 3

Se desplegará la siguiente ventana en donde tenemos que activar la casilla Constantes

 

 

Al pulsar en Aceptar podemos ver que únicamente se seleccionaran las celdas que contienen algún valor. Ahora podemos copiar estos datos de manera inmediata y pegarlos donde sea requerido.

 

 

Este es el primer método que podemos usar para copiar datos excluyendo las celdas vacías en Excel 2016.

 


2. Cómo copiar datos sin celdas vacías usando formulas

 

Paso 1

En Excel 2016 existen una serie de fórmulas diseñadas para facilitar el trabajo con datos y para este caso no es la excepción.
En este caso debemos usar una formula matricial y para ello la segmentaremos para su explicación.
Usaremos la siguiente formula:
=SI(A$1:A$9<>""; FILA(A$1:A$9))

 

En este caso la formula se encarga de validar cada celda del rango indicado, en este caso A1:A9, y si la celda esta vacía emitirá el mensaje FALSO, y si encuentra algún valor devolverá el número de la fila donde se encuentra dicho valor.

 

Paso 2

Ahora nuestro interés es obtener los números que indican donde existen datos y descartar las celdas que arrojan FALSO usaremos la función K.ESIMO.MENOR y la formula será la siguiente:
=K.ESIMO.MENOR(SI(A$1:A$9<>""; FILA(A$1:A$9)); FILAS(C$1:C1))
En esta fórmula el primer argumento que hemos usado es el arreglo que hemos creado en la formula anterior y el segundo argumento hace referencia al sitio donde deseamos sean desplegados los resultados de la formula.

 

 

 

Paso 3

Si copiamos la formula a las demás celdas veremos el siguiente resultado:

 

 

Podemos ver que la función K.ESIMO.MENOR devuelve la respectiva posición donde existe algún dato.

 

Paso 4

Ahora si deseamos obtener el valor de cada celda con datos y no solamente su posición debemos usar la función INDICE, usando la siguiente sintaxis:
=INDICE(A:A; K.ESIMO.MENOR(SI(A$1:A$9<>""; FILA(A$1:A$9)); FILAS(C$1:C1)))
Podemos ver el nuevo resultado:

 

 

 

Paso 5

Finalmente podemos agregar la función SI para que dentro del resultado no obtengamos el error #¡NUM!
Usaremos la siguiente formula:
=SI(FILAS(C$1:C1)>CONTARA(A:A); ""; INDICE(A:A; K.ESIMO.MENOR(SI(A$1:A$9<>""; FILA(A$1:A$9)); FILAS(C$1:C1)))
El resultado obtenido será el siguiente.

 

 

 

Podemos ver que se han omitido las celdas que contienen el mensaje de error. Usando alguna de estas alternativas podremos copiar las celdas que únicamente incluyen datos en Excel 2016.

 

¿Te ha gustado y ayudado este Tutorial?
Puedes premiar al autor pulsando este botón para darle un punto positivo
  • -
  • 0
10
VOTA
5
100%
4
0%
3
0%
2
0%
1
0%

  Información

  •   Publicado dic 22 2016 14:33
  •   Actualizado dic 22 2016 14:47
  •   Visitas 5.2K
  •   Nivel
    Avanzado



Tutoriales Relacionados


Sin comentarios, sé el primero!

No esperes más y entra en Solvetic
Deja tus comentarios y aprovecha las ventajas de la cuenta de usuario ¡Únete!
Demuestra que eres experto!
  ESCRIBIR TUTORIAL
Suscribirse